Иллюстрированный самоучитель по Office2003



              


Использование ссыпок в формуле


Формула может содержать ссылку на ячейку (ее адрес) или на диапазон ячеек, а также на имена, представляющие ячейки или диапазоны ячеек. Для описания ссылок на диапазоны ячеек используются операторы, приведенные в таблице 16.3.

Таблица 16.3. Операторы ссылки


Операторы ссылки


Значение (пример)


: (двоеточие)


Ставится между ссылками на первую и последнюю ячейки диапазона. Такое сочетание является ссыпкой на диапазон (В5:В15).


; (точка с запятой)


Оператор объединения. Объединяет несколько ссылок в одну ссылку (СУММ(В5:В15;О5:В15)).


(пробел)


Оператор пересечения множеств, служит для ссылки на общие ячейки двух диапазонов (B7:D7 С6:С8).

Чтобы сослаться на диапазон ячеек, введите ссылку на верхнюю левую ячейку диапазона, поставьте двоеточие (:), а затем — ссылку на правый нижний угол диапазона. Например, А2:С5. Ссылка на все ячейки между 6-й и 15-й строками включительно имеет вид 6:15, на все ячейки в столбце С — С:С.

Для задания обращения ко всем ячейкам, находящимся в нескольких диапазонах одновременно используется пересечение. Для задания пересечения диапазонов используется пробел. Например, формула =СУММ(А2:ВЗ В2:СЗ) вычисляет сумму чисел в пересекающихся диапазонах А2:ВЗ и В2:СЗ. Для обращения ко всем ячейкам, включенным в два диапазона, используется объединение. Если в ячейке ВЗ записано Петров, а ячейке A3 — Владимир, то формула АЗ=ВЗ&", "&АЗ будет означать объединение указанных выше имен, разделенных запятой (Петров, Владимир). При использовании операторов объединения и пересечения удобно пользоваться именованными диапазонами.

В формулу можно вводить ссылки на ячейки различных рабочих листов и книг. Ссылки, распространяющиеся на несколько рабочих листов, называются трехмерными. Ячейка, содержащая формулу, называется зависимой ячейкой. Ее значение зависит от значений ячеек, на которые имеются ссылки в формуле.

Примеры записей диапазонов ячеек в функции:

  • =СУММ(Е:Е) — определяется сумма числовых значений, содержащихся в столбце Е;
  •  =СУММ(Е2:С5) — подсчитывается сумма числовых значений, расположенных в диапазоне от Е2 до G5;
  •  =СУММ(5:5) — суммируются данные всех ячеек пятой строки;
  •  =СУММ(2;4) — подсчитывается сумма 2+4.
  • Допускается смешанная запись адресов ячеек и блоков ячеек. В этом случае формула может выглядеть следующим образом:

    =СУММ(С8;О4;Е2:Е5;Р5)




    Содержание  Назад  Вперед